Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

No chart data after NT8 offered futures rollover

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    No chart data after NT8 offered futures rollover

    Hi,

    I have not used NT8 for a month. After starting NT8 futures rollover was offered and I accepted it. After that no TS datafeed, no chart data only Loading... messages on chart windows. First I upgraded IB TWS and NT8 to the latest. The situation improved the TS window has data now. I assume the data connection is OK between IB TWS and NT8. But the charts still in Loading... state. I have checked the rollover dates. IB TWS has Sept15 rollover date, NT8 has Sept 13 rollover date for NQ. I edited it to Sept 15 but the situation is the same. I am asking help what steps should I do to have chart data. NT8 ver: 8.1.1.7 64-bit.

    Waiting for your support,

    Regards,
    Mihaly

    #2
    Hello mmiterli,

    Thank you for your post.

    I would first like to ensure that you are using the fully supported version of Trader Workstation (10.19.1k) or Gateway (110.19.1k) as outlined in your Interactive Brokers Connection Guide Below:You may find the version you are using by going to Help > About within Trader Workstation or Gateway.

    If you are not using these listed version then I would recommend uninstalling the current version you are using and then using the download links in the Connection Guide above to install the supported versions.

    Also please note that Interactive Brokers does have historical data limitations that if hit can take a long time for charts to load.

    These are outlined in the link below:

    https://interactivebrokers.github.io...mitations.html

    We advise starting with only one chart window set to a 1 minute data series and loading 1-2 days worth of data to test.
    Spencer F.NinjaTrader Customer Service

    Comment


      #3
      Hi Spencer,

      Thank you your quick reply. As requested 10.19.1k installed. PC is Win11. Reduced the workspace to 3 charts, 1min - 1day for NQ0923, FDAX0923 futures, 1day - 30day for AAPL stock download period in Data Series dialog. Situation is the same, Loading... status for more than 30 minutes. I think the problem is general, not connected to the futures because AAPL chart do the same as futures chart, loading only. I have checked all the steps given in the Connecting to Your Interactive Brokers Account document and it is OK. TS windows for the NQ0923, FDAX0923 futures are working right.

      Please advise how to proceed forward.

      Regards,

      Mihaly

      Comment


        #4
        Hello,

        Thank you for your post.

        This would still point towards the historical data limitations.

        To test do your charts load after manually downloading historical data from the Historical Data window under the Control Center > Tools > Historical Data?

        For more information on downloading historical data you may follow the link below:
        Spencer F.NinjaTrader Customer Service

        Comment


          #5
          Hi Spencer,

          Checked the historical data. Futures data are complete for 0623. For 0923 the data complete up to 09.07. On 1007 FDAX have data up to 16.00 and NQ up to 19.45. Current time is 20.33. Still no chart data displayed. Checked the IB limitations on datafeed requests. Because of the one month data download request in 1 min resolution for 3 instruments seem to me not a hard case. As the database shows the futures data almost complete.

          Comment


            #6
            Hello mmiterli,

            Thank you for your post.

            ​Let's try testing your platform in Safe Mode to verify if this behavior is being caused by a 3rd-party add-on using the steps below.

            Safe Mode will prevent NinjaTrader from:
            • Loading workspaces and connecting on start-up.
            • Loading custom assemblies (i.e. 3rd-party add-ons and NinjaScripts)
            • Getting instrument updates from the server
            To enable Safe Mode, please use the following steps:
            • Shut down NinjaTrader.
            • Go to the Windows Start Button
            • Search for NinjaTrader (Safe Mode)
            • Launch NinjaTrader (Safe Mode)
            Once you have opened the platform in Safe Mode:
            • Reconnect to your Data Provider
            • Please open a new chart with no custom bar types/indicators/templates and test for issues.
            • Please limit it to a 1 minute data series with 1 day of data to load
            Does the behavior persist on this blank Workspace in Safe Mode?
            • If not, please try opening your previous workspace by going to the Control Center > Workspaces drop-down. It may already show as being open. Hit 'close' and do not save and then re-open it again for your windows to re-appear. You will notice that no 3rd-party add-ons are running in Safe Mode.
            Does the behavior return on your regular Workspace in Safe Mode?
            • If not, restart NinjaTrader, and test for the behavior on your Workspace normally once more with your 3rd-party add-ons available. If this reintroduces issues, I suggest rebuilding your workspace, adding 1 add-on at a time.
            • Please keep track of what add-ons you add back in to identify the cause of the behavior if it returns.

            If it does not return, it indicates the error was isolated only to your other Workspace. I also suggest making a backup of your workspace so we can restore a working version of it if the issue returns. You will want to keep this backup file on an external hard drive or uploaded to a cloud drive such as Google Drive, Dropbox, or OneDrive.

            To create a backup, go to the Control Center > Tools > Export > Backup File. Additional information about backups may be read in our Help Guide linked here: NinjaTrader 8 Help Guide — Backup and Restore

            Spencer F.NinjaTrader Customer Service

            Comment


              #7
              Hi Spencer,

              Thank you your detailed reply. I have already reached my stoploss in time trying to fix this issue. Due to this reason I deinstalled cleanly and reinstalled NT8. The charts woring well now, I have to redo the templates but it is not a big deal. Sorry not to have a root cause of what the problem was.

              Thank you again your help!

              Rgards,

              Mihaly

              Comment


                #8
                The Main Problem with NT8 regarding external market data is that NT8 has neither API Log file, nor connection attempts recorded into general Log. That prevents investigation of connection problems.
                So great request for NT8 Development team is to copy best practices from IB TWS - provide dedicated API Log file t\for all external requests!

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by MatthewLesko, 05-21-2021, 09:37 PM
                4 responses
                164 views
                0 likes
                Last Post Mahmad1323  
                Started by samish18, Today, 03:02 PM
                3 responses
                15 views
                0 likes
                Last Post bltdavid  
                Started by Jakub, Today, 11:06 AM
                1 response
                16 views
                0 likes
                Last Post NinjaTrader_LuisH  
                Started by samish18, Today, 03:50 AM
                10 responses
                19 views
                0 likes
                Last Post samish18  
                Started by Mestor, 06-03-2018, 10:09 AM
                16 responses
                2,872 views
                0 likes
                Last Post myaha1000  
                Working...
                X