Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Historical Data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Historical Data

    Is there any way to get historical data further back than what is in the dropdown list in Instrument Manager? I've been using IB to fill my historical data for the ES and it was good until Dec 2007. Each time, I just select the dates that it's the forward month and then merge them together. The list seems to end at 10-07 and then says "##-##". Is there any way to get contract data for the Sept 07 contract and further back?

    Thanks,

    DK

    Originally posted by NinjaTrader_Josh View Post
    8DTK8,

    Please go to Tools->Options->Misc->Reset Instruments. See if that helps.

    #2
    Hello,


    So the Expiry drop down is does not give you an option further back than what you indicate below? If this is the case, that data is not available. If this is not the case, then just select the expiry you want the remove and add back the instrument on the Default list to sample the data.
    DenNinjaTrader Customer Service

    Comment


      #3
      Lengthier historical data

      I guess the data is not available with my current setup using the IB data farm.

      Can someone let me know where I can find data that goes further back and how to merge it with my current ES data which spans Sept. 9th, 2007 until now? Ideally I would like to go back as far as possible. I don't need tics. Minute granularity is great (I rarely look at anything below 5 min. And I'm only looking for ES data right now (would rather not buy a package with tons of symbols and real time data if I don't have to).

      Many thanks,

      Comment


        #4
        Hello,


        Here is a list of the data providers we support if want to contact them to see what they provide:



        I know eSignal supports a continuous contract that you may want to look into.
        DenNinjaTrader Customer Service

        Comment


          #5
          Error.

          I have followed the instructions outlined in:



          Everything went very smoothly until I tried to import. I selected the one file that I had exported from TS and I get a big red circle with an "X" in it and it says "There has been error on importing historical data. Please check the log."

          Now I don't know what the problem is or where this "log" is. Can anyone help me?

          Thanks,

          D

          Comment


            #6
            Nevermind

            I figured it out (I'm sure as countless others have). You just have to change the naming of the output file from TS to match something that looks like the output file of what NT puts out when it exports and everything runs smoothly.

            Best,

            DK

            Originally posted by 8DTK8 View Post
            I have followed the instructions outlined in:



            Everything went very smoothly until I tried to import. I selected the one file that I had exported from TS and I get a big red circle with an "X" in it and it says "There has been error on importing historical data. Please check the log."

            Now I don't know what the problem is or where this "log" is. Can anyone help me?

            Thanks,

            D

            Comment


              #7
              parsing historical minute data -> daily format

              Does anyone know of any tools or have any advanced programming skills that can convert/consolidate the 1 min data files into a daily format?

              Comment


                #8
                Hello,


                We do not have any system to convert the files but you can chart a 1440 minute chart to get a rough daily chart. There are 1440 minutes in a day.
                DenNinjaTrader Customer Service

                Comment


                  #9
                  ZB chart

                  I'm trying to put up a chart of the ZB.
                  Using the search, I can find it in the Instrument Manager, but for whatever reason I only have 'Globex' in the details section where there is a pulldown menu for Exchange:. Seeing that ZB is on ECBOT, it makes sense that leaving it on Globex doesn't work.

                  Can someone help me?

                  Thanks.

                  Comment


                    #10
                    Hello,

                    If you remove the instrument from the Default instrument list by clicking the ">" button in Tools>Instrument manager, then go to Tools>Options>Misc tab>Reset Instruments, then add the instrument back using the "<" button, then click OK you should get the default settings that are correct for the ZB.
                    DenNinjaTrader Customer Service

                    Comment


                      #11
                      I tried that but it still only says Globex as you can see in the attached screenshot.
                      Anything else I can try? Thanks.

                      Originally posted by NinjaTrader_Ben View Post
                      Hello,

                      If you remove the instrument from the Default instrument list by clicking the ">" button in Tools>Instrument manager, then go to Tools>Options>Misc tab>Reset Instruments, then add the instrument back using the "<" button, then click OK you should get the default settings that are correct for the ZB.
                      Attached Files

                      Comment


                        #12
                        Hello,

                        I pull up the ZB 12-08 fine with an IB connection using the Globex. You are not able to?

                        Try openning a chart and selecting the instrument drop down from the tool bar. What exchange does it say to the right of it?
                        DenNinjaTrader Customer Service

                        Comment


                          #13
                          Still having issues

                          I am trying to use IQFeed for data that goes further back. I am enclosing the error message that I get using your methods. If you think it matters, I can try using IB but it won't fix the current problem which is my desire to use information that is further back.

                          Your continued assistance is greatly appreciated.

                          On the pulldown menu, it says 'globex' after 'ZB 12-08' and 'ZB ##-##'. Thanks.

                          Originally posted by NinjaTrader_Ben View Post
                          Hello,

                          I pull up the ZB 12-08 fine with an IB connection using the Globex. You are not able to?

                          Try openning a chart and selecting the instrument drop down from the tool bar. What exchange does it say to the right of it?
                          Attached Files

                          Comment


                            #14
                            Unfortunately the ZB does not have a symbol mapping for IQFeed by default. Please see the IQFeed symbol guide at the link below for the corrrect symbol mapping.


                            Go to Tools-->instrument Manager and remove the ZB from your instrument list. Update the instrument with the correct symbol mapping and add the instrument backto your list.

                            Check if you receive data.
                            JasonNinjaTrader Customer Service

                            Comment


                              #15
                              Historical Tick

                              I have bought yet found them today after much searching. They look reasonable.

                              If one of the NINJA team could vet them it would be great!

                              http://www.anfutures.com/


                              Thanks much.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by janefoster, Yesterday, 11:50 PM
                              0 responses
                              5 views
                              0 likes
                              Last Post janefoster  
                              Started by kaywai, 07-13-2024, 09:05 PM
                              3 responses
                              27 views
                              0 likes
                              Last Post kaywai
                              by kaywai
                               
                              Started by stafe, Yesterday, 01:32 PM
                              2 responses
                              20 views
                              0 likes
                              Last Post stafe
                              by stafe
                               
                              Started by Jakub, Yesterday, 11:06 AM
                              2 responses
                              24 views
                              0 likes
                              Last Post ashpang
                              by ashpang
                               
                              Started by MatthewLesko, 05-21-2021, 09:37 PM
                              4 responses
                              167 views
                              0 likes
                              Last Post Mahmad1323  
                              Working...
                              X