Announcement

Collapse

Looking for a User App or Add-On built by the NinjaTrader community?

Visit NinjaTrader EcoSystem and our free User App Share!

Have a question for the NinjaScript developer community? Open a new thread in our NinjaScript File Sharing Discussion Forum!
See more
See less

Partner 728x90

Collapse

unsolicited "Fill Limit Orders on Touch" behavior

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    unsolicited "Fill Limit Orders on Touch" behavior

    "Fill Limit Orders on Touch" is not enabled in my strategy (set to False in my script and also unchecked in the strategy properties box). Yet, my strategy is filling limit orders on touch. It was working correctly yesterday afternoon, no changes have been made on my end, but last night and this morning it is demonstrating this behavior. I am testing my strategy in Market Replay playback and this unsolicited behavior results in a significant P&L difference. Has anyone encountered and/or resolved this type of issue? Thanks...

    #2
    Hello pkr75, thanks for your question.

    This setting ties into the historical backfill algorithm described here:
    https://ninjatrader.com/support/help...fill_logic.htm

    When not enabled, the step in this algorithm will be ignored. If you want to simulate some slippage for bars that can support the number of slippage ticks, enter a value into the "Slippage" field.

    Kind regards,
    -ChrisL
    Chris L.NinjaTrader Customer Service

    Comment


      #3
      Thank you for the quick response Chris. I am familiar with the link that you referenced related to the mechanics of the historical backfill algo. In my particular case, I am using Market Replay playback and "Fill limit order on touch" is not enabled. So I am not sure why my limit orders are being filled on touch. Other than State.SetDefaults and the strategy properties box, is there any other place where this property may have been accidentally enabled?

      Comment


        #4
        Hello pkr75, thanks for your reply.

        No, there is no other way this can be enabled for a strategy instance. With this property disabled the historical fill algorithm is being used normally. Try adding a higher resolution fill series for more accurate order fill estimation. Set Order Fill Resolution to High, then choose a smaller period series to fill orders upon (1 tick being the smallest possible series).

        Kind regards,
        -ChrisL
        Chris L.NinjaTrader Customer Service

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by DerkWehler, Today, 11:35 AM
        10 responses
        21 views
        0 likes
        Last Post DerkWehler  
        Started by tkaboris, Today, 01:42 PM
        1 response
        4 views
        0 likes
        Last Post NinjaTrader_Jesse  
        Started by dbennett3, Today, 01:59 PM
        0 responses
        1 view
        0 likes
        Last Post dbennett3  
        Started by webus, Today, 06:22 AM
        4 responses
        18 views
        0 likes
        Last Post webus
        by webus
         
        Started by DayTradingDEMON, 07-11-2024, 08:54 AM
        16 responses
        48 views
        0 likes
        Last Post DayTradingDEMON  
        Working...
        X