No announcement yet.

Partner 728x90


Interactive brokers not closing positions

  • Filter
  • Time
  • Show
Clear All
new posts

    Interactive brokers not closing positions

    Hello, I'm facing an issue using IB as broker and datafeed connected to Ninja, on FXDM and FXDS when I already have a position open and an ATM strategy running, if I decide to close the position, Ninja only closes pending OCO orders but the position remains open. So I need to close it manually in TWS.
    Can you advise ASAP??

    Thank you for your post.

    CRITICAL — If your inquiry involves live orders, please always reach out to your broker's Orders Desk immediately to confirm and manage your live orders and positions.

    Please make sure to use the 10.16.1k version of TWS or IB Gateway, listed in our Connection Guide as other versions may have unintended results.
    Please also make sure you are on the latest version of NinjaTrader — (or, which will be available on our website in a few hours), under "Control Center>Help>About" you can see what release you are using.

    To update NinjaTrader, please follow the steps below:
    • First, copy your license key from NinjaTrader under Help> License Key then exit NinjaTrader
    • Click on the link:
    • Enter your license key and press Submit
    • Select 'Download'
    • Critical: Before running the installer, ensure NinjaTrader is closed.

    Then reset instruments and repair DB, following steps below.
    1. First, disconnect from any data providers by navigating to the Control Center > Connections menu, and left-click on “disconnect” that appears to the right when hovering your mouse over any active connection
    2. Next, reset your instruments by navigating to the Control Center > Tools > Database Management
    3. In the Database Management window, under the “Update instruments” section, ensure that “General properties”, "Futures expiries" and “Symbol mappings” options are checked and then click Update
    4. Under the “Repair DB” section, click Repair
    5. Lastly, restart NinjaTrader for the changes to occur

    Please connect in the IB Trader’s Workstation first and then connect in the NinjaTrader, by going to Control Center>Connect and selecting your IB connection.

    If you continue to experience the same, please send us your log and trace files so that we may look into what occurred.

    You can do this by going to the Control Center-> Help-> Email Support

    Ensuring 'Log and Trace Files' is checked will include these files. This is checked by default.

    Please reference the following ticket number in the body of the email: 03547991​
    Oxana R.NinjaTrader Customer Service


      Hi Oxana, I already run the versions you outlined in your post.
      I'm facing the problem only with FDXM and the FDXS (EUREX DAX futures).
      As suggested I repaired the database but for some reason for those symbols, on the interactive brokers Symbol Map I get:
      DAX-disabled|EUREX||1 for FXDS
      DAX-disabled|EUREX||5 for FXDM

      So for those I'm forced to modify them to
      DAX|EUREX||1 for FXDS
      DAX|EUREX||5 for FXDM

      for them to be streamed, so maybe that's the problem...
      I will try one more trade and let you know.



        Thank you for the note.

        When using Interactive Brokers, the symbol mapping for the FDAX, FDXS and FDXM are the same. They have a separate multipliers to identify each one.

        Since the symbol mapping is the same, the symbol mapping can only be included for one at a time in the Instrument Manager.

        By default, the FDXM and FDXS are disabled. It's only to use one of these instruments at a time.

        To use FDXM instead of FDAX, please follow steps below:
        • From the Control Center, navigate to Tools -> Instruments.
        • Search for FDXM.
        • Once found, click on the symbol in the list and select "edit".
        • Scroll down to the Symbol Mapping for Interactive Brokers and delete the "-disabled" part of this Parameter.
        • Click "OK" to save your changes.

        Once this is done, please disable the FDAX instrument.
        • From the Control Center, navigate to Tools -> Instruments.
        • Search for FDAX.
        • Once found, click FDAX and select "edit".
        • Scroll down to the Symbol Mapping for Interactive Brokers and add in the "-disabled" just after the instrument name. This will look almost exactly like the FDXM instrument did before.
        • Click "OK" to save your changes.

        After that, please restart the NinjaTrader platform.

        Please let us know if you have any further questions.
        Oxana R.NinjaTrader Customer Service


          Dear Oxana,
          all good now, I followed the steps you outlined and disabled the contracts I won't trading. Now everything works ok.
          Thank you


          Latest Posts


          Topics Statistics Last Post
          Started by tradgrad, Today, 11:36 AM
          0 responses
          Last Post tradgrad  
          Started by SteveReiza, Today, 10:59 AM
          2 responses
          Last Post SteveReiza  
          Started by GKonheiser, 10-02-2012, 06:08 AM
          48 responses
          Last Post NinjaTrader_BrandonH  
          Started by patdmoney, Today, 10:55 AM
          2 responses
          Last Post patdmoney  
          Started by linkcou, Yesterday, 03:14 PM
          7 responses
          Last Post NinjaTrader_Emily