Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

CliSecure Protecting Your Code

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    In the second PC I have the NT version 7, and other strategies do not give me error. thanks

    Comment


      #17
      Mariano,

      There is essentially 4 causes for this that are the most common.

      A) There is an error in the strategy you are trying to import.

      B) One of the PC's has NT 6.5 whereas the strategy was created in NT 7, or vice verci.

      C) One of the PC's has a non-compilable state due to errors in indicators or strategies.

      D) One of the PC's is missing an indicator that the strategy is using.

      You need to be sure the PC you are importing the strategy into is in a compilable state by attempting to compile on them before you import the indicator.

      You then need to be sure both PC's have the same version of NinjaTrader.

      You then need to be sure that the Strategy doesn't have any errors when you compile it.

      You then need to be sure that the Second PC has all the indicators that the strategy uses on it as well.

      If you could possible take some screen shots of these steps it would help us in remedying the issue.

      How to take a screenshot on your smartphone, tablet, notebook or desktop computer
      Adam P.NinjaTrader Customer Service

      Comment


        #18
        If you use in the first PC: "export compiled assembly", (v) Protect compiled assemblies, in the second PC I can import that strategy?

        Comment


          #19
          Mariano,

          "Protect compiled assemblies" only works if you have a license to use the Secure-Team product.

          Agile.net is a best-in-class obfuscator for .NET platform. Agile.net protects .NET applications against piracy, code theft & malicious tampering.


          Otherwise, you can use "Export compiled assembly" but the code will not be protected from decompiling.
          Adam P.NinjaTrader Customer Service

          Comment


            #20
            on the second PC I have not installed CliSecure, why not let me import a strategy compiled?.Thanks

            Comment


              #21
              Thank you. I have a license in the first PC, CliSecure 5.3
              for NinjaTrader

              Comment


                #22
                Mariano,

                Could you perhaps email me this indicator so I can take a look at it? I suspect its missing a file in its assembly, but we can isolate whether or not there is a compiling issue if I can import.

                You also need to make sure that the system you are importing protected assemblies on is authorized to have them. This is used for developers to ensure that their indicators are licensed.

                You can send the indicator to [email protected] with ATTN adam in the message body.
                Adam P.NinjaTrader Customer Service

                Comment


                  #23
                  Thank you very much. Fixed encryption issue.
                  Please, How to put "two" time slots( 90000-110000 and 150000-170000). I have an example of a time slot.
                  if (Totime (Time [0])> HoraSalida | | Totime (Time [0]) <HoraEntrada)
                  {
                  ExitShort ("", "");
                  ExitLong ();
                  return;
                  }
                  Last edited by MarianoMA; 12-05-2011, 08:54 PM.

                  Comment


                    #24
                    Hello MarianoMA,

                    You can structure valid time ranges using the right logical operators. Here is the example you were looking for:

                    How to put "two" time slots( 90000-110000 and 150000-170000)

                    Code:
                    if ((ToTime(Time [0])> 90000 && ToTime(Time [0]) < 110000) || (ToTime(Time [0]) > 150000 && ToTime(Time [0]) < 170000)) { }
                    Ryan M.NinjaTrader Customer Service

                    Comment


                      #25
                      After upgrading to NinjaTrader 7.0.1000.8 I get this message, when I try to export a protected assembly.

                      Please advise what to do. No problems with prior versions.


                      Edit: Problem is solved, NinjaTrader 7.0.1000.8 requires upgrade of CliSecure to release 5.4.
                      Attached Files
                      Last edited by Harry; 12-13-2011, 05:33 PM.

                      Comment


                        #26
                        Thank you, does not work. I think so.

                        if (ToTime (Time [0])> 0 & & ToTime (Time [0]) <90000 | | ToTime (Time [0])> 110000 & & ToTime (Time [0]) <150000 | | ToTime (Time [0] )> 170000 & & ToTime (Time [0]) <240000)
                        {
                        ExitShort ("", "");
                        ExitLong ();
                        return;
                        }

                        Comment


                          #27
                          MarianoMA,

                          For the time ranges you have to be very careful with parentheses and operators in order to create the right expression. While you can do it all in one condition, but it may also be easier to follow if you structure as multiple bool conditions.

                          Code:
                          bool timeRange1 = ToTime(Time[0])> 0 && ToTime (Time[0]) < 90000;
                          bool timeRange2 = ToTime(Time[0])> 110000 && ToTime (Time[0]) < 150000;
                          bool timeRange3 = ToTime(Time[0])> 170000 && ToTime (Time[0]) < 240000;
                          			
                          			
                          if(timeRange1 || timeRange2 || timeRange3) {}
                          Ryan M.NinjaTrader Customer Service

                          Comment


                            #28
                            Can you please provide the Link to the latest version of CliSecure for NT users.

                            Thanks.
                            Last edited by NinjaTrader_Brett; 12-14-2011, 09:07 AM.

                            Comment


                              #29
                              Guys, we've looked further into and the needed CLISecure version would not change going from R7 to R8.

                              If you get the message that an outdated CLISecure is used, please unsinstall current NT7R8 and redownload the installer fresh from here : http://www.ninjatrader.com/download-registration.php

                              The CLISecure version used would stay at the 5.3.1.0 release.

                              Thanks,
                              Last edited by NinjaTrader_Bertrand; 12-14-2011, 06:15 AM.
                              BertrandNinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by Johnny Santiago, 10-11-2019, 09:21 AM
                              95 responses
                              6,193 views
                              0 likes
                              Last Post xiinteractive  
                              Started by xiinteractive, 04-09-2024, 08:08 AM
                              2 responses
                              11 views
                              0 likes
                              Last Post xiinteractive  
                              Started by Irukandji, Today, 09:34 AM
                              1 response
                              3 views
                              0 likes
                              Last Post NinjaTrader_Clayton  
                              Started by RubenCazorla, Today, 09:07 AM
                              1 response
                              5 views
                              0 likes
                              Last Post RubenCazorla  
                              Started by TraderBCL, Today, 04:38 AM
                              3 responses
                              25 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Working...
                              X