Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Why can I not get daily bars?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Why can I not get daily bars?

    I have a strategy that I wanted to run on daily bars, but I never seem to get any bars returned.

    To eliminate chance that I introduced a bug, all of the following is based on running the SampleMACrossOver strategy in the strategy analyzer.

    I have tried running it with a TD Ameritrade connection live. When requesting 1 min or 390 min bars from Strategy Analyzer, I get results. When I make the same request, except for 1 day bars, I hit a breakpoint in Initialize(), but not in OnBarUpdate() (and in my custom strategy it also does not hit a breakpoint in OnStartUp()).

    I thought that Kinetick, Yahoo, and Google provided data as 1 day bars, so I tried each of them. I could not hit the breakpoint in OnBarUpdate() with any of them with 1 min, 390 min, or 1 day bars.

    The symbols I used were IBM and AAPL and the date ranges 10-1-11 to 10-24-11.

    When I ran with data that I had stored historically on my machine (by running a strategy with 1 min bars), the strategy ran correctly with 1 min bars and appeared to be correct with 390 min bars, but did not hit OnBarUpdate() with 1 day bars.

    Is it safe to assume that 390 min bars will begin and end with each trading day? This sounds risky.

    Am I making an incorrect assumption about how NinjaTrader and/or the data providers are supposed to work?

    Thanks

    #2
    Hello,

    You should be receiving daily data from all of these connections you tried.

    Can you please tell me which version of NinjaTrader you are using, NT V7.0.1000.7? You can check this under Help--> About.

    What session template do you have applied when you run the backtest? Do you get results when using the Default 24/7 session template?

    I look forward to assisting you further.
    MatthewNinjaTrader Product Management

    Comment


      #3
      Originally posted by NinjaTrader_Matthew View Post
      Hello,

      You should be receiving daily data from all of these connections you tried.

      Can you please tell me which version of NinjaTrader you are using, NT V7.0.1000.7? You can check this under Help--> About.

      What session template do you have applied when you run the backtest? Do you get results when using the Default 24/7 session template?

      I look forward to assisting you further.
      I am running NT V7.0.1000.6. I will try updating.

      The session was set to "<use instrument settings>" which should translate to "US Equities RTH".

      Thanks

      Comment


        #4
        Thanks please let me know how it works on NT V7.0.1000.7 as there was a minor fix in this area.
        MatthewNinjaTrader Product Management

        Comment


          #5
          The new version seems to have fixed the problem.

          Thanks

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by franatas, 06-03-2024, 11:41 PM
          9 responses
          31 views
          0 likes
          Last Post franatas  
          Started by sugarCost, Today, 01:12 AM
          0 responses
          4 views
          0 likes
          Last Post sugarCost  
          Started by rtwave, Yesterday, 12:10 AM
          3 responses
          17 views
          0 likes
          Last Post rtwave
          by rtwave
           
          Started by Mckcrd, Yesterday, 10:49 PM
          0 responses
          10 views
          0 likes
          Last Post Mckcrd
          by Mckcrd
           
          Started by royzech, Yesterday, 09:06 PM
          0 responses
          8 views
          0 likes
          Last Post royzech
          by royzech
           
          Working...
          X