Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

proprietary indicators for versions 6.5 vs. 7?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    proprietary indicators for versions 6.5 vs. 7?

    Hello,
    I thought I'd ask someone about this before I go and crash my Ninjatrader. I bought some proprietary indicators which are somehow coded so they need to recognize the Machine ID of my computer. The folks who made these indicators gave me their versions for both Ninja 6.5 and Ninja 7, but they warned me not to install both sets on the same computer because they didn't know what would happen. So, I have both NT 6.5 and NT 7.0 on this computer, and I use them both (but not at the same time), and I've loaded their indicators for NT 6.5 on this machine. What will happen if I unzip the version of their indicators for NT 7.0? When I go to start NT 7.0, will it crash both versions of Ninja? Only one version? Will it be OK? Am I on my own here? Just curious. If anybody knows the likely outcome, please let me know. This has got to be an issue that some people are facing with other proprietary indicators--there's buckets of them out there for Ninja. BTW, the indicators come from TopDogTrading, Dr. Barry Burns' website, and the indicators are really great---surprisingly sophisticated (or maybe not so surprising, Barry's a really good trader).
    Thanks,
    Tasuki
    Last edited by Tasuki; 02-19-2011, 11:00 PM.

    #2
    NinjaTrader 6.5 and NinjaTrader 7.0 are two different programs. If you install an assembly for NT 7.0 this has no impact on NinjaTrader 6.5 and vice versa. However, there are some rules to respect:

    (1) Only use assemblies for NT 6.5 with NT 6.5
    (2) Only use assemblies for NT 7.0 with NT 7.0
    (3) Protected assemblies, which were supplied for NT 7.0.1000.2 and earlier will not run on NT 7.0.1000.3 and later.

    You need to ask your vendor TopDogTrading to update all NT 7 assemblies for use with NT 7.0.1000.3

    Comment


      #3
      Originally posted by Harry View Post
      NinjaTrader 6.5 and NinjaTrader 7.0 are two different programs. If you install an assembly for NT 7.0 this has no impact on NinjaTrader 6.5 and vice versa. However, there are some rules to respect:

      (1) Only use assemblies for NT 6.5 with NT 6.5
      (2) Only use assemblies for NT 7.0 with NT 7.0
      (3) Protected assemblies, which were supplied for NT 7.0.1000.2 and earlier will not run on NT 7.0.1000.3 and later.

      You need to ask your vendor TopDogTrading to update all NT 7 assemblies for use with NT 7.0.1000.3
      I have 6.5 and a lot of custom indicators (none from vendors)--many written with forum help, others downloaded from the forum.
      I want to keep ninja but dump zenfire but my broker said only zenfire supports 6.5.
      2 questions--how can i tell which of my custom indicators from 6.5 will work on 7.0 without any recoding and if i download 7.0 does it kill my use of 6.5?
      My scripting skills are more a result of copying parts of one indicator into the script for a different indicator and playing with it until it works--but recoding a 6.5 indicator for 7.0 looked very daunting. Please DO NOT just reply with a link that supposedly explains the method because that was beyond my skillset months ago.
      Thanks.

      Comment


        #4
        simpletrades, NinjaTrader 6.5 and 7 can be installed on the same PC at the same time and used as desired by you - you would need to import indicator on NT7 and then test, we have compiled a few code breaking changes here if you're interested - http://www.ninjatrader.com/support/f...ad.php?t=21016

        For migrating over to NT7, I would suggest taking some time to review the migration guide we put together -

        BertrandNinjaTrader Customer Service

        Comment


          #5
          thanks, i'll look thru the migration guide later but the code breaking changes is the kind of wording i dont understand. i recognize barcolor and session bars from some scripts, but it was always copy and paste for me, not writing from scratch--upgrading barcolor i can probably due for my paintbars and re-color for my background as the indicator moves from buy to sell etc..but session bars, chart control and whether an indicator i used overrode plot method is gibberish to me. sorry.

          Comment


            #6
            Originally posted by simpletrades View Post
            thanks, i'll look thru the migration guide later but the code breaking changes is the kind of wording i dont understand.
            Yeah, I'm curious myself. What does "code-breaking" mean?

            Tasuki

            Comment


              #7
              It means that code that worked on 6.5 needs changing to work on 7 then, as underlying NinjaScript language changes / enhancements occurred.
              BertrandNinjaTrader Customer Service

              Comment


                #8
                you said i could alternately use 6.5 and 7.0 but that doesnt do it.

                i tried that last nite. Now 7.0 works, but when i click the 6.5 icon instead i get the error "the feature you are trying to use is on a network resource that is unavailable.

                Click OK to try again or enter an alternate path to a folder containing the installation package 'tmpE8.tmp' in the box below..

                This is my home desktop, not some network. 6.5 and 7.0 are each in separate prpgram files folders and their indicators, templates etc.. are in separate folders in my documents. why did 7.0 kill 6.5?

                if it matters i am using windows xp.
                Last edited by simpletrades; 02-26-2011, 06:39 AM.

                Comment


                  #9
                  simpletrades, did you originally install NT6.5 on a network drive or a network location?
                  AustinNinjaTrader Customer Service

                  Comment


                    #10
                    Originally posted by NinjaTrader_Austin View Post
                    simpletrades, did you originally install NT6.5 on a network drive or a network location?
                    no, this is my home desktop.
                    the only other computer is my daughter's notebook.

                    Comment


                      #11
                      NinjaTrader 6.5 and NT7 are completely independent as far as files and settings are concerned, so I am not sure why your NT6.5 install doesn't work after installing NT7. Please try a complete uninstall and reinstall of NT6.5 and let us know if you're still having issues after that.
                      AustinNinjaTrader Customer Service

                      Comment

                      Latest Posts

                      Collapse

                      Topics Statistics Last Post
                      Started by Touch-Ups, Today, 08:42 AM
                      0 responses
                      7 views
                      0 likes
                      Last Post Touch-Ups  
                      Started by obiwan_cashobi, Today, 05:50 AM
                      0 responses
                      12 views
                      0 likes
                      Last Post obiwan_cashobi  
                      Started by janefoster, Yesterday, 11:50 PM
                      0 responses
                      8 views
                      0 likes
                      Last Post janefoster  
                      Started by kaywai, 07-13-2024, 09:05 PM
                      3 responses
                      34 views
                      0 likes
                      Last Post kaywai
                      by kaywai
                       
                      Started by stafe, Yesterday, 01:32 PM
                      2 responses
                      31 views
                      0 likes
                      Last Post stafe
                      by stafe
                       
                      Working...
                      X